Testnet: default, testnet-g networks behind
Incident Report for drand
Resolved
We identified the issue and patched it, though have abandoned the ceremony
Posted Feb 21, 2024 - 17:35 UTC
Investigating
While preparing for our ceremony, all networks (but quicknet-t) got behind. We're investigating.
Posted Feb 21, 2024 - 16:09 UTC