Increased error rate on relays

Incident Report for drand

Monitoring

/latest is back. v2 APIs still showing some issues, but error rate has dropped to normal levels again. We'll continue monitoring for the time being.
Posted Apr 22, 2026 - 15:04 UTC

Investigating

We're investigating an increased error rate on both mainnet and testnet relays. `/latest` and the v2 APIs are affected, but calling rounds directly or `/public/0` (effectively latest) seems unaffected
Posted Apr 22, 2026 - 14:43 UTC